package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(1)?([.\-\ ])?(\()?(\d{3})?(\))?([.\-\ ])?(\d{3})?([.\-\ ])?(\d{4})?$`)
var str = `15095315910`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}