$re = '/^(1)?([.\-\ ])?(\()?(\d{3})?(\))?([.\-\ ])?(\d{3})?([.\-\ ])?(\d{4})?$/i';
$str = '15095315910';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);