# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+):\s?(\w+);/@property {$2} $1/gm;t' <<< " AllowMagazine: boolean;
Badge: string;
BirthDay: number;
Blocked: boolean;
BusNr: string;
CardQty: number;
CityID: number;
CityName: string;
CityZip: string;
CountryISOCode: string;
CustomerID: number;
DirectReduction: boolean;
Email: string;
FirstName: string;
Gender: string;
IsActive: boolean;
LanguageISO: string;
LastName: string;
Mailing: boolean;
Mobile: string;
Phone: string;
Pincode: string;
Reduction: number;
ReductionAllowed: boolean;
Street: string;
StreetNr: string;
"