use strict;
my $str = ' AllowMagazine: boolean;
Badge: string;
BirthDay: number;
Blocked: boolean;
BusNr: string;
CardQty: number;
CityID: number;
CityName: string;
CityZip: string;
CountryISOCode: string;
CustomerID: number;
DirectReduction: boolean;
Email: string;
FirstName: string;
Gender: string;
IsActive: boolean;
LanguageISO: string;
LastName: string;
Mailing: boolean;
Mobile: string;
Phone: string;
Pincode: string;
Reduction: number;
ReductionAllowed: boolean;
Street: string;
StreetNr: string;
';
my $regex = qr/(\w+):\s?(\w+);/mp;
my $subst = '@property {$2} $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";