import Foundation
let pattern = #"(\w+):\s?(\w+);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AllowMagazine: boolean;
Badge: string;
BirthDay: number;
Blocked: boolean;
BusNr: string;
CardQty: number;
CityID: number;
CityName: string;
CityZip: string;
CountryISOCode: string;
CustomerID: number;
DirectReduction: boolean;
Email: string;
FirstName: string;
Gender: string;
IsActive: boolean;
LanguageISO: string;
LastName: string;
Mailing: boolean;
Mobile: string;
Phone: string;
Pincode: string;
Reduction: number;
ReductionAllowed: boolean;
Street: string;
StreetNr: string;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@property {$2} $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)