package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\<data\>\s*(?<data>[^<]+)`)
var str = `<ID> 100034566 </ID> <data> This consists of DB data </data> <date> the date is 04-03-2019 </data>..........etc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}