# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\s*\\/?\s*img(?![^>]*class=)/$0 class="whatever"/g;t' <<< "<img src=\"https://google.com/animage.jpg\" class=\"google\"><img src=\"https://yahoo.com/animage.jpg\"><img src=\"https://google.com/animage.jpg\" class=\"google\"><img src=\"https://google.com/animage.jpg\" class=\"google\"><img src=\"https://yahoo.com/animage.jpg\"><img src=\"https://yahoo.com/animage.jpg\"><img src=\"https://yahoo.com/animage.jpg\">"