#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<\s*\/?\s*img(?![^>]*class=)"
Local $sString = "<img src="https://google.com/animage.jpg" class="google"><img src="https://yahoo.com/animage.jpg"><img src="https://google.com/animage.jpg" class="google"><img src="https://google.com/animage.jpg" class="google"><img src="https://yahoo.com/animage.jpg"><img src="https://yahoo.com/animage.jpg"><img src="https://yahoo.com/animage.jpg">"
Local $sSubst = "$0 class="whatever""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)