import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*\\/?\\s*img(?![^>]*class=)";
final String string = "<img src=\"https://google.com/animage.jpg\" class=\"google\"><img src=\"https://yahoo.com/animage.jpg\"><img src=\"https://google.com/animage.jpg\" class=\"google\"><img src=\"https://google.com/animage.jpg\" class=\"google\"><img src=\"https://yahoo.com/animage.jpg\"><img src=\"https://yahoo.com/animage.jpg\"><img src=\"https://yahoo.com/animage.jpg\">";
final String subst = "$0 class=\"whatever\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}