# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\bhttps?://\S+/)[^\s?#/]+(?![^\s?#])"
test_str = ("For any of the following URLs, I'm looking for a match for segment as follows:\n\n"
" https://example.com/what-not/segment matches segment\n"
" https://example.com/what-not/segment?a=b matches segment\n"
" https://example.com/what-not/segment#a matches segment\n\n"
"In case there is a match for segment, I'm going to replace it with segment/.\n\n"
"For any of the following URLs, there should be no match:\n\n"
" https://example.com/what-not/segment/ no match\n"
" https://example.com/what-not/segment/?a=b no match\n"
" https://example.com/what-not/segment/#a no match\n")
subst = "$1segment/"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.