using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]{3}\s[0-9]{3}\s[0-9]{4}$|^.[0-9]{2}\s[0-9]{2}\s[0-9]{3}\s[0-9]{4}";
string input = @"082 689 0343
082 689 0343
+27 82 689 0343
082 689 0343
+23 73 343 0234
0732343234
07 3234 3234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}