import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9]{3}\\s[0-9]{3}\\s[0-9]{4}$|^.[0-9]{2}\\s[0-9]{2}\\s[0-9]{3}\\s[0-9]{4}";
final String string = "082 689 0343\n"
+ "082 689 0343\n"
+ "+27 82 689 0343\n"
+ "082 689 0343\n"
+ "+23 73 343 0234\n"
+ "0732343234\n"
+ "07 3234 3234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}