re = /^[0-9]{3}\s[0-9]{3}\s[0-9]{4}$|^.[0-9]{2}\s[0-9]{2}\s[0-9]{3}\s[0-9]{4}/m
str = '082 689 0343
082 689 0343
+27 82 689 0343
082 689 0343
+23 73 343 0234
0732343234
07 3234 3234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end