package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/CATALOG\/(sort-price\/|code\/sort-price\/)num[0-9]{1,}\/page[0-9]{1,}\/`)
var str = `
/CATALOG/code/sort-price/num48/page2/
/CATALOG/sort-price/num48/page2/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}