$re = '/\/CATALOG\/(sort-price\/|code\/sort-price\/)num[0-9]{1,}\/page[0-9]{1,}\//m';
$str = '
/CATALOG/code/sort-price/num48/page2/
/CATALOG/sort-price/num48/page2/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);