re = /\/CATALOG\/(sort-price\/|code\/sort-price\/)num[0-9]{1,}\/page[0-9]{1,}\//m
str = '
/CATALOG/code/sort-price/num48/page2/
/CATALOG/sort-price/num48/page2/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end