// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/CATALOG\/(sort-price\/|code\/sort-price\/)num[0-9]{1,}\/page[0-9]{1,}\/").unwrap();
let string = "
/CATALOG/code/sort-price/num48/page2/
/CATALOG/sort-price/num48/page2/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}