import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(?!(https*://)*((127)|(192\\.168)|(0\\.0\\.0\\.0)))(?:(?:https*://)|^))(?:(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2})\\.(?:2[0-5][0-5]|1[0-9]{2}|[0-9]{1,2}))(?=[^\\d\\s]|$)";
final String string = "http://127.0.0.1\n"
+ "127.0.0.1\n"
+ "http://192.168.0.155\n"
+ "192.168.0.155\n"
+ "https://0.0.0.0\n\n"
+ "25.61.12.6\n"
+ "http://193.168.0.155\n"
+ "http://148.251.8.11\n"
+ "115.148.63.10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}