const regex = /^order-wkcda-[\d_]{1,}\.xml$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^order-wkcda-[\\d_]{1,}\\.xml$', 'g')
const str = `order-wkcda-20210615_042706949.xml`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}