re = /^https?:\/\/[-a-z0-9.]*linkedin\.com\/.*$/m
str = 'https://a.subdomain.linkedin.com/a/b/c/d/e'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end