#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z0-9.!#$%&'*+\/=?^_`{|}~-]+@[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?(?:\.[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?)+;)+$"
Local $sString = "user1@xxx.com;" & @CRLF & _
"user1@xxx.com;user2@xxx.com;" & @CRLF & _
"user1@xxx.com;user2@xxx.com;user3@xxx.com;" & @CRLF & _
"" & @CRLF & _
"user1@xxx.com" & @CRLF & _
"user1@xxx" & @CRLF & _
"user1@xxx.com;user2@xxx.com "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")