const regex = /^(?<sexe>[1-478])\s*?(?<annee>[0-9]{2})\s*?(?<mois>0[1-9]|1[0-2]|[2-3][0-9]|4[0-2]|[5-9][0-9])\s*?(?<departement>2[ABab]|[0-9]{2}|9[7-8][0-9])\s*?(?<commune>[0-9]{3}|[0-9]{2})\s*?(?<ordre>00[1-9]|0[1-9][0-9]|[1-9][0-9]{2})\s*?(?<cle>0[1-9]|[1-8][0-9]|9[0-7])\s*?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<sexe>[1-478])\\s*?(?<annee>[0-9]{2})\\s*?(?<mois>0[1-9]|1[0-2]|[2-3][0-9]|4[0-2]|[5-9][0-9])\\s*?(?<departement>2[ABab]|[0-9]{2}|9[7-8][0-9])\\s*?(?<commune>[0-9]{3}|[0-9]{2})\\s*?(?<ordre>00[1-9]|0[1-9][0-9]|[1-9][0-9]{2})\\s*?(?<cle>0[1-9]|[1-8][0-9]|9[0-7])\\s*?$', 'gm')
const str = `100089932132111
2 80 05 17 001 001 01
Cas Spécifiques définis ici : https://fr.wikipedia.org/wiki/Num%C3%A9ro_de_s%C3%A9curit%C3%A9_sociale_en_France
=> Naissance à l'étranger en cours d'immatriculation en France avec mois de naissance pseudo-fictif (état-civil incomplet)
8 00 31 99 901 001 02
=> Naissance en Outre-Mer
2 00 01 987 01 001 02`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}