package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x) \$ \w+ #variable name
(?:
(?:( \. ) #method call `.`
( \S+ ) # method name
)?
( \( ) # function open paren
( .*?) # function arguments
( \) ) # function close paren
)? `)
var str = `"$created.url ~ "#$origin.human-kind() $origin.name()".subst(:g, /\s+/, '_')
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}