using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:\/user.?\s*:(.?\S*)))";
string input = @" /node:asdf /user:asfsdfd /password:1q2w£1!`
/node:asdf /user:asfsdfd /password:1q2w£1!`
/user:asfsdfd /node:asdf /password:1q2w£1!`
/password:1q2w£1!` /user:asfsdfd /node:asdf
/password:1q2w£1!` /user:asfsdfd /node:asdf
/password:1q2w£1!` /user :asfsdfd /node :asdf
/password :1q2w£1!` /user: asfsdfd /node : asdf
/password:1q2w£1!` /user: asfsdfd /node : asdf
/password:1q2w£1!` /user : ""asfsdfd /node : asdf
/node:""hostb"" /user :""administrator"" /password:""quick-radio-cat-88""
/user :""administrator"" /node:""hostb"" /password:""quick-radio-cat-88""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}