package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(?:\/user.?\s*:(.?\S*)))`)
var str = ` /node:asdf /user:asfsdfd /password:1q2w£1!\`
/node:asdf /user:asfsdfd /password:1q2w£1!\`
/user:asfsdfd /node:asdf /password:1q2w£1!\`
/password:1q2w£1!\` /user:asfsdfd /node:asdf
/password:1q2w£1!\` /user:asfsdfd /node:asdf
/password:1q2w£1!\` /user :asfsdfd /node :asdf
/password :1q2w£1!\` /user: asfsdfd /node : asdf
/password:1q2w£1!\` /user: asfsdfd /node : asdf
/password:1q2w£1!\` /user : "asfsdfd /node : asdf
/node:"hostb" /user :"administrator" /password:"quick-radio-cat-88"
/user :"administrator" /node:"hostb" /password:"quick-radio-cat-88"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}