use strict;
my $str = ' /node:asdf /user:asfsdfd /password:1q2w£1!`
/node:asdf /user:asfsdfd /password:1q2w£1!`
/user:asfsdfd /node:asdf /password:1q2w£1!`
/password:1q2w£1!` /user:asfsdfd /node:asdf
/password:1q2w£1!` /user:asfsdfd /node:asdf
/password:1q2w£1!` /user :asfsdfd /node :asdf
/password :1q2w£1!` /user: asfsdfd /node : asdf
/password:1q2w£1!` /user: asfsdfd /node : asdf
/password:1q2w£1!` /user : "asfsdfd /node : asdf
/node:"hostb" /user :"administrator" /password:"quick-radio-cat-88"
/user :"administrator" /node:"hostb" /password:"quick-radio-cat-88"';
my $regex = qr/(?:(?:\/user.?\s*:(.?\S*)))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}