$re = '/(?:(?:\/user.?\s*:(.?\S*)))/m';
$str = ' /node:asdf /user:asfsdfd /password:1q2w£1!`
/node:asdf /user:asfsdfd /password:1q2w£1!`
/user:asfsdfd /node:asdf /password:1q2w£1!`
/password:1q2w£1!` /user:asfsdfd /node:asdf
/password:1q2w£1!` /user:asfsdfd /node:asdf
/password:1q2w£1!` /user :asfsdfd /node :asdf
/password :1q2w£1!` /user: asfsdfd /node : asdf
/password:1q2w£1!` /user: asfsdfd /node : asdf
/password:1q2w£1!` /user : "asfsdfd /node : asdf
/node:"hostb" /user :"administrator" /password:"quick-radio-cat-88"
/user :"administrator" /node:"hostb" /password:"quick-radio-cat-88"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);