# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\r\n]+(?:\r?\n(?!\s*[a-z][)])[^\r\n]*)*"
test_str = ("Os Embargos de Terceiros fazem parte do procedimento especial, previsto no Código de Processo Civil, sendo possível sua utilização por quem, não sendo parte no processo, sofre constrição ou sofre ameaça de constrição sobre bens que possua ou sobre os quais tenha direito incompatível com o ato constritivo. Sobre o ajuizamento dos embargos, assinale a alternativa INCORRETA.\n\n"
"Considere o segmento “[...] o Estado só percebe o eco enfraquecido.†(2º§). Pode-se afirmar que a partir do recurso de linguagem utilizado pelo enunciador na escolha da palavra “Estadoâ€, identifica-se 7\n\n"
"a) o estabelecimento de uma comparação entre “Estado†e “governantesâ€.\n"
"b) o emprego de uma palavra redundante objetivando reforçar a ideia expressa.\n"
" questões que irão ter várias quebra de linhas\n\n\n\n\n"
" questões que irão ter várias quebra de linhas\n\n\n"
"c) uma transferência de percepções resultando em uma fusão de impressões sensoriais.\n"
"d) a evocação de um termo em lugar de uma palavra, com a qual se acha relacionada não sendo sinônimos. ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.