using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(href|src)=""((https*:\/\/)([\w\d\.]+))*\/([\w\d\/]+)\.(jpg|jpeg|png|gif)";
string input = @"href=""http://example.com/_pu/0/filename.jpg""
href=""https://example.com/_pu/0/filename.jpg""
href=""/_pu/0/filename.jpg""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}