$re = '/[a-zA-Z0-9._]*@[a-zA-Z0-9-]*\.[a-z]*/m';
$str = 'name_lastname@hotmail.com
name.lastname@gmail.com
user@domainname.nl
user@domain-name.tld
help@911.com
party@club.amsterdam
toys@web.shop';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);