# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^_.]*\K_[^._]+(?=\.[^.]+$)//gm;t' <<< "4711_001.doc"