#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)get_aval_stock\s*\(\s*.*\s*,\s*.*\s*,\s*.*\s*,\s*.*\s*,\s*'[ANOPZ]'\s*.*\)"
Local $sString = " /* Start PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */" & @CRLF & _
" /*AND SOU_FORECAST.get_aval_stock(con.coid,con.scid,p_r_sou_tariff.arid,0) <> 0*/" & @CRLF & _
" AND SOU_FORECAST.get_aval_stock(" & @CRLF & _
"con.coid," & @CRLF & _
"con.scid ,p_r_sou_tariff . arid," & @CRLF & _
"0 ," & @CRLF & _
"'O' ) <> 0" & @CRLF & _
"and costam costam;" & @CRLF & _
" /* End PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")