const regex = /get_aval_stock\s*\(\s*.*\s*,\s*.*\s*,\s*.*\s*,\s*.*\s*,\s*'[ANOPZ]'\s*.*\)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('get_aval_stock\\s*\\(\\s*.*\\s*,\\s*.*\\s*,\\s*.*\\s*,\\s*.*\\s*,\\s*\'[ANOPZ]\'\\s*.*\\)', 'gi')
const str = ` /* Start PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */
/*AND SOU_FORECAST.get_aval_stock(con.coid,con.scid,p_r_sou_tariff.arid,0) <> 0*/
AND SOU_FORECAST.get_aval_stock(
con.coid,
con.scid ,p_r_sou_tariff . arid,
0 ,
'O' ) <> 0
and costam costam;
/* End PKO 20200428 EXOG-1104_Uniezaleznienie_blokowania_dostawcy_od_godziny_odciecia_zamowienia.docx */`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}