re = /^(\d+(-\d+)?, )*\d+(-\d+)?$/m
str = '1
1, 4-5
1, 4-5, 8, 11, 13-14
1,,,,
1, 4-5-
1, 4--------2233-----,,,,
1, 2, 3, 4, 5
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end