package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d*[\d.]*?)\.?0*$`)
var str = `9.25000
11.000
1.02345
2.0300
0.0000
90000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}