$re = '/(?<!\<a\shref)my(?!.*\<\/a\>)/mi';
$str = 'This is a sample my text <a href="https://test.com">test my stuff</a> with my inside <a href="https://mytest.com">test me</a> brackets and my outside brackets oh my . <a href="https://test.com">test my stuff</a> not sure why my instances of my before the last lookahead doesnt work?
Intent: I have an FAQ that uses js to highlight words on the page by letter as you type. I need to ignore the HREF entries in the replace function as the injection of a class to highlight the typed letters/words replaced within the HREF messing up the link.
Incorrectly Ignoring position 18, 76, 141, 164
Correctly ignoring position 58, 104 and 201
Correctly finding position 227, 242';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);