import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\"([^\"]*)\";){3}";
final String string = "\"/activities/absenceactivity/lang/#LANG_ID#/prop_dialog.php\";\"BA2_PD_SCR\";\"Opis dogodka\";\"Event description\";\"Descrição do Evento\";\"ÐÐ¿Ð¸Ñ Ð¿Ð¾Ð´ÑÑ\";\"\";\"č®vykio aprašymas\";\"Descripción del evento\";\"\";";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}