use strict;
my $str = '0782342323
0041782342323
+41782342323
078.234.23.23
004178.234.23.23
+4178.234.23.23
078-234-23-23
004178-234-23-23
+4178-234-23-23
078 234 23 23
004178 234 23 23
+4178 234 23 23';
my $regex = qr/(\+41|0041|0){1}(\(0\))?[0-9]{2}[\s.-]?[0-9]{3}[\s.-]?[0-9]{2}[\s.-]?[0-9]{2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}