import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\"'])(?:(?=(\\\\?))\\2.)*?\\1";
final String string = "UPDATE `wp_options` SET `option_value` = 'a:1151:{s:15:\\\"activ\";}' WHERE `option_name` = 'my_options';\n\n"
+ "INSERT INTO Customers (CustomerName, ContactName, Address, City, PostalCode, Country)\n"
+ "VALUES ('Cardinal', 'Tom B. Erichsen', 'Skagen 21', 'Stavanger', '4006', 'Norway');";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}