// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)([^\?#]*\w)((?:/#|#)?)([^\?]*)($|\?.*)").unwrap();
let string = "https://demo.wofll.com/#/demo?a=1&b=2";
let substitution = "$1/index.html$2$3$4";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}