using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[^;\n\r\t])""(?=[^;\n\r\t])";
string substitution = @"";
string input = @"""ModifTextePub"";""ModifObservation"";""Resume""Vitrine"";""Observations""Criteres"";""InternetOK"";""NumPhoto"";""AmianteLe"";""SNavantLe"";""ActePrec"";""ProprietairesPrec"";""Situation"";""FraisNotaires""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}