re = /(?<=[^;\n\r\t])"(?=[^;\n\r\t])/
str = '"ModifTextePub";"ModifObservation";"Resume"Vitrine";"Observations"Criteres"";"InternetOK";"NumPhoto";"AmianteLe";"SNavantLe";"ActePrec";"ProprietairesPrec";"Situation";"FraisNotaires"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result