import re
regex = re.compile(r"(n\'t|\'m|\'ll|\'ve|\'s|\'re|\'d)", flags=re.MULTILINE)
test_str = "should've can't mustn't we'll"
subst = " \\1"
result = regex.sub(subst, test_str)
if result:
print(result)