re = /(n\'t|\'m|\'ll|\'ve|\'s|\'re|\'d)/m
str = 'should\'ve can\'t mustn\'t we\'ll'
subst = ' \\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result