const regex = /\w(\d+_\d+_)\w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w(\\d+_\\d+_)\\w+', 'gm')
const str = `S1_2_S1_test.txt
S2_2_S18_test.txt
S3_2_S9_test.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}