const regex = /^0+(?!\.0+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0+(?!\\.0+$)', 'gm')
const str = `0.00
000.00
000123
00001230
00123.30`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);