import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([jJ][aA][cC][kK]\\s[cC][aA][rR][tT][eE][rR]|[jJ][aA][cC][kK]\\s[aA-zZ]\\s[cC][aA][rR][tT][eE][rR]|[jJ][aA][cC][kK]\\s[aA-zZ][.]\\s[cC][aA][rR][tT][eE][rR])";
final String string = "Jack Carter\n"
+ "Jack C Carter\n"
+ "Jack Z. Carter\n"
+ "JAck Carter\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}