const regex = /([jJ][aA][cC][kK]\s[cC][aA][rR][tT][eE][rR]|[jJ][aA][cC][kK]\s[aA-zZ]\s[cC][aA][rR][tT][eE][rR]|[jJ][aA][cC][kK]\s[aA-zZ][.]\s[cC][aA][rR][tT][eE][rR])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([jJ][aA][cC][kK]\\s[cC][aA][rR][tT][eE][rR]|[jJ][aA][cC][kK]\\s[aA-zZ]\\s[cC][aA][rR][tT][eE][rR]|[jJ][aA][cC][kK]\\s[aA-zZ][.]\\s[cC][aA][rR][tT][eE][rR])', 'gm')
const str = `Jack Carter
Jack C Carter
Jack Z. Carter
JAck Carter
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}