package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)box(?:es|[sx])?`)
var str = `box
boxes
boxs
boxx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}