#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)q$|^w"
Local $sString = "weekend" & @CRLF & _
"hello" & @CRLF & _
"yummy" & @CRLF & _
"working" & @CRLF & _
"seq" & @CRLF & _
"sequence" & @CRLF & _
"bird" & @CRLF & _
"puzzle" & @CRLF & _
"wholesome"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")